import re
regex = re.compile(r"(^| )hoi($| )|(^| )hallo($| )|(^| )ok($| )|(^| )doei($| )", flags=re.MULTILINE)
test_str = ("ik zag hem en toen zei hij hallo\n"
"hoi hoe is het\n"
"het is ok blijkbaar\n"
"doei\n"
"twee hallos werkt niet\n"
"hhhhoi stotterde hij\n"
"doeiii")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")