const regex = new RegExp('(^| )hoi($| )|(^| )hallo($| )|(^| )ok($| )|(^| )doei($| )', 'gm')
const str = `ik zag hem en toen zei hij hallo
hoi hoe is het
het is ok blijkbaar
doei
twee hallos werkt niet
hhhhoi stotterde hij
doeiii`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}