import Foundation
let pattern = #"(^| )hoi($| )|(^| )hallo($| )|(^| )ok($| )|(^| )doei($| )"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ik zag hem en toen zei hij hallo
hoi hoe is het
het is ok blijkbaar
doei
twee hallos werkt niet
hhhhoi stotterde hij
doeiii
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)