$re = '/(^| )hoi($| )|(^| )hallo($| )|(^| )ok($| )|(^| )doei($| )/m';
$str = 'ik zag hem en toen zei hij hallo
hoi hoe is het
het is ok blijkbaar
doei
twee hallos werkt niet
hhhhoi stotterde hij
doeiii';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);