import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Diagnosis Statement:\\s*.*\\s*\\K^([A-Z0-9]{16})$";
final String string = "Diagnosis Statement:\n"
+ "6/28/2011\n"
+ "RZZZCG77T77G355S\n"
+ "Report text is here ....... end of report\n\n"
+ "Diagnosis Statement:\n"
+ "6/28/2011\n"
+ "RZZZCG77T77G355S\n"
+ "Report text is here ....... end of report\n\n"
+ "This must not match because there is not the magic words before!\n"
+ "RZZZCG77T77G355S\n\n"
+ "This must match, even if there is no date between the magic words and the thing to match :\n\n"
+ "Diagnosis Statement:\n"
+ "RZZZCG77T77G355S\n"
+ "Report text is here ....... end of report";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}