$re = '/Diagnosis Statement:\s*.*\s*\K^([A-Z0-9]{16})$/m';
$str = 'Diagnosis Statement:
6/28/2011
RZZZCG77T77G355S
Report text is here ....... end of report
Diagnosis Statement:
6/28/2011
RZZZCG77T77G355S
Report text is here ....... end of report
This must not match because there is not the magic words before!
RZZZCG77T77G355S
This must match, even if there is no date between the magic words and the thing to match :
Diagnosis Statement:
RZZZCG77T77G355S
Report text is here ....... end of report';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);