import Foundation
let pattern = #"Diagnosis Statement:\s*.*\s*\K^([A-Z0-9]{16})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Diagnosis Statement:
6/28/2011
RZZZCG77T77G355S
Report text is here ....... end of report
Diagnosis Statement:
6/28/2011
RZZZCG77T77G355S
Report text is here ....... end of report
This must not match because there is not the magic words before!
RZZZCG77T77G355S
This must match, even if there is no date between the magic words and the thing to match :
Diagnosis Statement:
RZZZCG77T77G355S
Report text is here ....... end of report
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)