import re
regex = re.compile(r"Diagnosis Statement:\s*.*\s*\K^([A-Z0-9]{16})$", flags=re.MULTILINE)
test_str = ("Diagnosis Statement:\n"
"6/28/2011\n"
"RZZZCG77T77G355S\n"
"Report text is here ....... end of report\n\n"
"Diagnosis Statement:\n"
"6/28/2011\n"
"RZZZCG77T77G355S\n"
"Report text is here ....... end of report\n\n"
"This must not match because there is not the magic words before!\n"
"RZZZCG77T77G355S\n\n"
"This must match, even if there is no date between the magic words and the thing to match :\n\n"
"Diagnosis Statement:\n"
"RZZZCG77T77G355S\n"
"Report text is here ....... end of report")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")