use strict;
my $str = 'Diagnosis Statement:
6/28/2011
RZZZCG77T77G355S
Report text is here ....... end of report
Diagnosis Statement:
6/28/2011
RZZZCG77T77G355S
Report text is here ....... end of report
This must not match because there is not the magic words before!
RZZZCG77T77G355S
This must match, even if there is no date between the magic words and the thing to match :
Diagnosis Statement:
RZZZCG77T77G355S
Report text is here ....... end of report';
my $regex = qr/Diagnosis Statement:\s*.*\s*\K^([A-Z0-9]{16})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}