#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\s\*)([^*]+)(\*\s)"
Local $sString = "test string *67* **Hi**"
Local $sSubst = "$1hello$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)