re = /(\s\*)([^*]+)(\*\s)/
str = 'test string *67* **Hi**'
subst = '$1hello$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result