use strict;
my $str = 'test string *67* **Hi**';
my $regex = qr/(\s\*)([^*]+)(\*\s)/p;
my $subst = '$1hello$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";