import Foundation
let pattern = #"(\s\*)([^*]+)(\*\s)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"test string *67* **Hi**"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1hello$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)