package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\s\*)([^*]+)(\*\s)`)
var str = `test string *67* **Hi**`
var substitution = "$1hello$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}