# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\[\[(?:(?:(?!\[\[|]]).)*+|(?-1)++)*]])|[^\t\n:\[\]]+|[\[\]]+/$1/gm;t' <<< "Delete: stuff: here [and here] : [[but not : here]] [[or [ here ]] :: ]REDACT[ :: [[or [:even:] [[[[::]]]] here]] OK?"