const regex = /(\[\[(?:(?:(?!\[\[|]]).)*+|(?-1)++)*]])|[^\t\n:\[\]]+|[\[\]]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[\\[(?:(?:(?!\\[\\[|]]).)*+|(?-1)++)*]])|[^\\t\\n:\\[\\]]+|[\\[\\]]+', 'gm')
const str = `Delete: stuff: here [and here] : [[but not : here]] [[or [ here ]] :: ]REDACT[ :: [[or [:even:] [[[[::]]]] here]] OK?`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);