re = /(\[\[(?:(?:(?!\[\[|]]).)*+|(?-1)++)*]])|[^\t\n:\[\]]+|[\[\]]+/m
str = 'Delete: stuff: here [and here] : [[but not : here]] [[or [ here ]] :: ]REDACT[ :: [[or [:even:] [[[[::]]]] here]] OK?'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result