using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[\[(?:(?:(?!\[\[|]]).)*+|(?-1)++)*]])|[^\t\n:\[\]]+|[\[\]]+";
string substitution = @"$1";
string input = @"Delete: stuff: here [and here] : [[but not : here]] [[or [ here ]] :: ]REDACT[ :: [[or [:even:] [[[[::]]]] here]] OK?";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}