$re = '/(\[\[(?:(?:(?!\[\[|]]).)*+|(?-1)++)*]])|[^\t\n:\[\]]+|[\[\]]+/m';
$str = 'Delete: stuff: here [and here] : [[but not : here]] [[or [ here ]] :: ]REDACT[ :: [[or [:even:] [[[[::]]]] here]] OK?';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;