#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\[\[(?:(?:(?!\[\[|]]).)*+|(?-1)++)*]])|[^\t\n:\[\]]+|[\[\]]+"
Local $sString = "Delete: stuff: here [and here] : [[but not : here]] [[or [ here ]] :: ]REDACT[ :: [[or [:even:] [[[[::]]]] here]] OK?"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)