use strict;
my $str = '<div class="wrapper">
<p>Parágrafo fora dos ifs.</p>
@if (true)
<div>Oi?</div>
@if (false)
<span>Não devo ser renderizado</span>
@endif
@endif
<p>Estou entre os if\'s</p>
@if (true)
<div>estou em outro if</div>
@endif
</div>';
my $regex = qr/@if(?:\s+|)\(([\s\S]*?)\)([\s\S]*?)+@endif/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}