// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)@if(?:\s+|)\(([\s\S]*?)\)([\s\S]*?)+@endif").unwrap();
let string = "<div class=\"wrapper\">
<p>Parágrafo fora dos ifs.</p>
@if (true)
<div>Oi?</div>
@if (false)
<span>Não devo ser renderizado</span>
@endif
@endif
<p>Estou entre os if's</p>
@if (true)
<div>estou em outro if</div>
@endif
</div>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}