import Foundation
let pattern = #"@if(?:\s+|)\(([\s\S]*?)\)([\s\S]*?)+@endif"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<div class="wrapper">
<p>Parágrafo fora dos ifs.</p>
@if (true)
<div>Oi?</div>
@if (false)
<span>Não devo ser renderizado</span>
@endif
@endif
<p>Estou entre os if's</p>
@if (true)
<div>estou em outro if</div>
@endif
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}