re = /@if(?:\s+|)\(([\s\S]*?)\)([\s\S]*?)+@endif/i
str = '<div class="wrapper">
<p>Parágrafo fora dos ifs.</p>
@if (true)
<div>Oi?</div>
@if (false)
<span>Não devo ser renderizado</span>
@endif
@endif
<p>Estou entre os if\'s</p>
@if (true)
<div>estou em outro if</div>
@endif
</div>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end