const regex = /(.*)(\-\..*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)(\\-\\..*)', 'gm')
const str = `filename.jpeg
filename-.png
file name.doc
file name 3.mp4
file name -.dxg
file.name.mov`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);