use strict;
my $str = 'filename.jpeg
filename-.png
file name.doc
file name 3.mp4
file name -.dxg
file.name.mov';
my $regex = qr/(.*)(\-\..*)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";