import re
regex = re.compile(r"(.*)(\-\..*)", flags=re.MULTILINE)
test_str = ("filename.jpeg\n"
"filename-.png\n"
"file name.doc\n"
"file name 3.mp4\n"
"file name -.dxg\n"
"file.name.mov")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)