re = /(.*)(\-\..*)/m
str = 'filename.jpeg
filename-.png
file name.doc
file name 3.mp4
file name -.dxg
file.name.mov'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result