$re = '/(.*)(\-\..*)/m';
$str = 'filename.jpeg
filename-.png
file name.doc
file name 3.mp4
file name -.dxg
file.name.mov';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;