# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\B(?<!\d)\d\b//gm;t' <<< "I am 2the number1
I am 3the number1abc
I am 4the number1 @#@%$grtuy
I am number1 1 and you number2 2
I am 5the number11 @#@%$grtuy
I am 6the number11"