#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\B(?<!\d)\d\b"
Local $sString = "I am 2the number1" & @CRLF & _
                "I am 3the number1abc" & @CRLF & _
                "I am 4the number1 @#@%$grtuy" & @CRLF & _
                "I am number1 1 and you number2 2" & @CRLF & _
                "I am 5the number11 @#@%$grtuy" & @CRLF & _
                "I am 6the number11"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)