using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\B(?<!\d)\d\b";
string substitution = @"";
string input = @"I am 2the number1
I am 3the number1abc
I am 4the number1 @#@%$grtuy
I am number1 1 and you number2 2
I am 5the number11 @#@%$grtuy
I am 6the number11";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}