$re = '/\B(?<!\d)\d\b/m';
$str = 'I am 2the number1
I am 3the number1abc
I am 4the number1 @#@%$grtuy
I am number1 1 and you number2 2
I am 5the number11 @#@%$grtuy
I am 6the number11';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;