import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\B(?<!\\d)\\d\\b";
final String string = "I am 2the number1\n"
+ "I am 3the number1abc\n"
+ "I am 4the number1 @#@%$grtuy\n"
+ "I am number1 1 and you number2 2\n"
+ "I am 5the number11 @#@%$grtuy\n"
+ "I am 6the number11";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}