const regex = /\B(?<!\d)\d\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\B(?<!\\d)\\d\\b', 'gm')
const str = `I am 2the number1
I am 3the number1abc
I am 4the number1 @#@%\$grtuy
I am number1 1 and you number2 2
I am 5the number11 @#@%\$grtuy
I am 6the number11`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);