const regex = /(!?(<.*?>)|[^<]+)\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(!?(<.*?>)|[^<]+)\\s*', 'gm')
const str = `<div class="testing" style="color:red" .... more attributes and id="test">text</div>
<div class="testing" ...some attributes... id="test".... some attributes....>text</div>
<div id="test" .........any number of attributes>text</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}