re = /(!?(<.*?>)|[^<]+)\s*/m
str = '<div class="testing" style="color:red" .... more attributes and id="test">text</div>
<div class="testing" ...some attributes... id="test".... some attributes....>text</div>
<div id="test" .........any number of attributes>text</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end