// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(!?(<.*?>)|[^<]+)\s*").unwrap();
let string = "<div class=\"testing\" style=\"color:red\" .... more attributes and id=\"test\">text</div>
<div class=\"testing\" ...some attributes... id=\"test\".... some attributes....>text</div>
<div id=\"test\" .........any number of attributes>text</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}