$re = '/(!?(<.*?>)|[^<]+)\s*/m';
$str = '<div class="testing" style="color:red" .... more attributes and id="test">text</div>
<div class="testing" ...some attributes... id="test".... some attributes....>text</div>
<div id="test" .........any number of attributes>text</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);