using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+(?=\d{4}$)";
string substitution = @"";
string input = @"December 2005
January 2008
January 3, 2001
December 18, 2004";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}