$re = '/\s+(?=\d{4}$)/m';
$str = 'December 2005
January 2008
January 3, 2001
December 18, 2004';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;