use strict;
my $str = 'December 2005
January 2008
January 3, 2001
December 18, 2004';
my $regex = qr/\s+(?=\d{4}$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";