re = /\s+(?=\d{4}$)/m
str = 'December 2005
January 2008
January 3, 2001
December 18, 2004'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result