const regex = /\s+(?=\d{4}$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+(?=\\d{4}$)', 'gm')
const str = `December 2005
January 2008
January 3, 2001
December 18, 2004`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);