# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(TRACE(\s*)\(\S+\s*[,](\s*\S+\s*)[,\n](\s*\S+\s*)[,](\s*))([^\"])/\1 "%s" \6/gm;t' <<< "TRACE(&logger_mr , DEBUG_2 , NULL ,
UdpPathMgmtLogger::entranceStr_sc;
"