import re
regex = re.compile(r"(TRACE(\s*)\(\S+\s*[,](\s*\S+\s*)[,\n](\s*\S+\s*)[,](\s*))([^\"])", flags=re.MULTILINE)
test_str = ("TRACE(&logger_mr , DEBUG_2 , NULL ,\n"
" UdpPathMgmtLogger::entranceStr_sc;\n")
subst = "\\1 \"%s\" \\6"
result = regex.sub(subst, test_str)
if result:
print(result)