#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(TRACE(\s*)\(\S+\s*[,](\s*\S+\s*)[,\n](\s*\S+\s*)[,](\s*))([^\"])"
Local $sString = "TRACE(&logger_mr , DEBUG_2 , NULL ," & @CRLF & _
" UdpPathMgmtLogger::entranceStr_sc;" & @CRLF & _
""
Local $sSubst = "\1 "%s" \6"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)