using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\+(?=(?:\s?\d){7,17}$)\d+(?:\s?\d+){0,3}$";
string input = @"+256897845
+1 232321
+29 2343 2432 43
+555 2356897845
+1245 2356878
+918989784578
Must include + Symbol on start
Optional Support up to 3 space Like: +29 2343 2432 43
Minimum 8 Char including + symbol
Max Char 18 digit (3 Space + 4 digit max country code + Plus (+) Symbol + 10 digit max number)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}