const regex = /^\+(?=(?:\s?\d){7,17}$)\d+(?:\s?\d+){0,3}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+(?=(?:\\s?\\d){7,17}$)\\d+(?:\\s?\\d+){0,3}$', 'gm')
const str = `+256897845
+1 232321
+29 2343 2432 43
+555 2356897845
+1245 2356878
+918989784578
Must include + Symbol on start
Optional Support up to 3 space Like: +29 2343 2432 43
Minimum 8 Char including + symbol
Max Char 18 digit (3 Space + 4 digit max country code + Plus (+) Symbol + 10 digit max number)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}