import Foundation
let pattern = #"^\+(?=(?:\s?\d){7,17}$)\d+(?:\s?\d+){0,3}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+256897845
+1 232321
+29 2343 2432 43
+555 2356897845
+1245 2356878
+918989784578
Must include + Symbol on start
Optional Support up to 3 space Like: +29 2343 2432 43
Minimum 8 Char including + symbol
Max Char 18 digit (3 Space + 4 digit max country code + Plus (+) Symbol + 10 digit max number)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)